org.apache.http.client.HttpResponseException: Range Not Satisfiable (416)

Today, i am working on a new spring boot new project.

But while i run the quickstart, it show me the error

Caused by: org.eclipse.aether.resolution.ArtifactResolutionException: Could not transfer artifact org.springframework.boot:spring-boot-dependencies:pom:1.5.8.RELEASE from/to central (http://repo1.maven.org/maven2/): Range Not Satisfiable (416)	at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:444)	at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:246)	at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:223)	at org.apache.maven.repository.internal.DefaultModelResolver.resolveModel(DefaultModelResolver.java:122)	... 38 moreCaused by: org.eclipse.aether.transfer.ArtifactTransferException: Could not transfer artifact org.springframework.boot:spring-boot-dependencies:pom:1.5.8.RELEASE from/to central (http://repo1.maven.org/maven2/): Range Not Satisfiable (416)	at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:43)	at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:355)	at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:67)	at org.eclipse.aether.connector.basic.BasicRepositoryConnector$DirectExecutor.execute(BasicRepositoryConnector.java:581)	at org.eclipse.aether.connector.basic.BasicRepositoryConnector.get(BasicRepositoryConnector.java:249)	at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:520)	at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:421)	... 41 moreCaused by: org.apache.http.client.HttpResponseException: Range Not Satisfiable (416)	at org.eclipse.aether.transport.http.HttpTransporter.handleStatus(HttpTransporter.java:466)	at org.eclipse.aether.transport.http.HttpTransporter.execute(HttpTransporter.java:291)	at org.eclipse.aether.transport.http.HttpTransporter.implGet(HttpTransporter.java:243)	at org.eclipse.aether.spi.connector.transport.AbstractTransporter.get(AbstractTransporter.java:59)	at org.eclipse.aether.connector.basic.BasicRepositoryConnector$GetTaskRunner.runTask(BasicRepositoryConnector.java:447)	at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:350)	... 46 more1 error

I search the google, then found the resolution

https://github.com/grails/grails-core/issues/9935

then i delete my ~/.m2/repository , and the problem was resolved.

Post: 2017

Views: 411

Follow me: @twitter @github
Scan QR code and Donate me via alipay:
donate me via alipay
Donate me Bitcoin:136MYemy5QmmBPLBLr1GHZfkES7CsoG4Qh
Powered by GoSense RSS